Android app crash connecting some cards

Please give as many details about the bug are you reporting as possible:

On attempting to connect a credit card from BIN 414720 (Chase), the 3DS page shows up, spins, and then the app crashes. This happens when I try again, when I try a different card from the same issuer, and after rebooting.

Steps to reproduce:

  1. Get a visa credit card issued by Chase
  2. Open the Android app and log in.
  3. Click “Your Wallet”
  4. Click “Connect Card”
  5. Enter the card information and press “Connect Card”
  6. Watch the embedded browser come up, spin, and then the app crash.

Where are you seeing this bug? When trying to connect a card issued by Chase. Note that I have successfully linked cards from other issuers. Maybe this issuer is declining the test charge and the app isn’t prepared to handle that?
If on one of our apps, what version of your software are you using, and what build of our app? Android eda86e109cc6314
When did you first notice the bug? 20/01/2022

Please add any screenshots you were able to take. It’s an app crash, the app exits and I see the home screen. If I try again, I get the Vitra keeps crashing message.

4 Likes

Hey @inY!

We don’t currently support Chase cards, which is the reason it’s crashing.

We are working on sorting the crash issue out so it just displays a ‘card currently not supported’ popup!

Hope this helps.

Ryan

3 Likes

Some people may also see this problem if the card they’re trying to add does not support 3DSecure. We are aware some credit cards don’t for some reason.

Layering cards, or as Ryan said, trying to add a card that’s not supported will also get this reaction.

As above, this issue is being worked on and should be fixed hopefully next week.

:smile:

4 Likes

The most interesting case is 430679.

As background, this issuer’s fraud alert system is terrible. They freak out on most of my normal activity and make me call in to unlock. Then when there was actually fraud on the card they didn’t notice and I spotted it and told them to reissue. That was months ago and I’m on the reissued card number.

Adding the card to Vitra was successful. But anything after that declined. Three separate calls to the frontline fraud alert phone number claimed to fix it but did not. Apparently I needed to talk to the “Rapid Response” team that’s ironically only open during business hours. They didn’t tell me what they did, but it was cleared up on the 4th call with that time. I was then able to use the card with a different merchant. But after they did that, the card disappeared from Vitra’s list of connected cards. And now the app crashes if I try to add it again.

3 Likes

Unfortunately this isn’t the first time we’ve heard of this. Another forum user told us an almost identical experience with another provider. It’s a shame.

Ahh. Yes. 10/10 logic there!

3 Likes

Could be worse. I wonder if anybody has tried to link Creation to Vitra lol.

3 Likes

I know the issue. Your bank had done nothing wrong, BUT NOT REQUIRING 3d secure. You should be able to add the card again next week.

And yes. It’s all about fraud prevention.

Do not get angry at old banks for being this way… they do what they can.

4 Likes

Ah so the fuller story here is the bank required 3DS the first time. Then after the “rapid response” team cleaned up, they marked it as manually approved and 3DS wasn’t required for a 0.00 charge (we think). Then the lack of 3DS requirement confused Vitra?

3 Likes

It did not confuse Vitra. We just can not accept it for safety reasons, unfortunately. But the problem is solved (just like paypall - for the cards, that do not mandate 3ds , we send a digit to your bank - and you will have to confirm the number in the app). I guess it’s being implemented now or implemented already. Should be available soon.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.